AWS Outage - Elevated errors on our backend infrastructure

Incident Report for Pix4D

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 10:13 UTC

Identified

Our cloud provider (AWS) is experiencing technical issues on multiple services we rely on, affecting the API and the processing infrastructure. Processing might be delayed or failing as a result.

For more details please check AWS incident page: https://health.aws.amazon.com/health/status?eventID=arn:aws:health:us-east-1::event/MULTIPLE_SERVICES/AWS_MULTIPLE_SERVICES_OPERATIONAL_ISSUE/AWS_MULTIPLE_SERVICES_OPERATIONAL_ISSUE_BA540_514A652BE1A
Posted Oct 20, 2025 - 07:00 UTC
This incident affected: Processing Infrastructures (Processing infrastructure US, Processing infrastructure DE, Processing infrastructure JP, Processing infrastructure KR, Processing infrastructure CA) and Pix4D Licensing system, PIX4Dcatch, PIX4Dcloud, PIX4Dengine Cloud API, PIX4Dfields, PIX4Dmapper, PIX4Dmatic, PIX4Dreact, PIX4Dsurvey.